FALF Player Forum Index FALF Player
music player for K Desktop Environment

FAQFAQ  SearchSearch  MemberlistMemberlist  UsergroupsUsergroups
RegisterRegister  Log inLog in

Previous topic «» Next topic
Crash
Author Message
jaro_t

OS: Linux
Joined: 19 Jun 2007
Posts: 3
Posted: 2007-07-03, 20:52   Crash

Run falf in console as root:

Welcome to FALF Player 1.0rc5dev (using libxine 1.1.2)!
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 7
Minor opcode: 0
Resource id: 0x30000cc
KCrash: Application 'falf' crashing...

FALF version 1.0rc5dev SVN revision 115. Revision 114 is O.K.

Jaro_T
 
     
Project Leader 
Administrator
Project Leader


FALF: 1.4dev
OS: Linux
Helped: 2 times
Joined: 30 Sep 2006
Posts: 74
Posted: 2007-07-04, 06:47   

Probably it's because of Your system or You use old conf file which may result in unexpected behaviour. I can't reproduce that crash. Recompile without striping binary file and paste backtrace.
 
     
jaro_t

OS: Linux
Joined: 19 Jun 2007
Posts: 3
Posted: 2007-07-04, 21:00   

Thi is new information:

(gdb) run
Starting program: /opt/falf/falf
Reading symbols from shared object read from target memory...done.
Loaded system supplied DSO at 0xbfffe000
[Thread debugging using libthread_db enabled]
[New Thread -1233942304 (LWP 4881)]
[New Thread -1241756768 (LWP 4899)]
[New Thread -1250186336 (LWP 4903)]
[New Thread -1258849376 (LWP 4904)]
Welcome to FALF Player 1.0rc5dev (using libxine 1.1.2)!
Restoring...

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1233942304 (LWP 4881)]
0xb75adfe8 in xine_set_param () from /usr/lib/libxine.so.1
Current language: auto; currently c
(gdb)

System Mandriva 2007

Best regard
Jaro_T
 
     
Project Leader 
Administrator
Project Leader


FALF: 1.4dev
OS: Linux
Helped: 2 times
Joined: 30 Sep 2006
Posts: 74
Posted: 2007-07-04, 21:31   

It's rather outdated xine-lib version, try update it first. If it won't help please write when exactly it occurs (first run, empty playlist, sound system, equalizer enabled etc.). As I mentioned unfortunately I cannot reproduce it (I use xine-lib 1.1.7).
 
     
Project Leader 
Administrator
Project Leader


FALF: 1.4dev
OS: Linux
Helped: 2 times
Joined: 30 Sep 2006
Posts: 74
Posted: 2007-07-05, 08:06   

I think it's because old xine doesn't handle null stream pointer in right way so FALF won't force xine to set parameters for null streams (try latest svn).
 
     
jaro_t

OS: Linux
Joined: 19 Jun 2007
Posts: 3
Posted: 2007-07-05, 10:02   

SVN revision 119 it's O.K.
Thanks.

Jaro_T
 
     
Display posts from previous:   
Reply to topic
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Add this topic to your bookmarks
Printable version

Jump to:  

Powered by phpBB modified by Przemo © 2003 phpBB Group